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THANK YOU 
Thank You for Purchasing from NEVCO.  

We appreciate your business. 

 

 

The following instructions will help you become familiar with the operation and features of your 

new software. Please take a few minutes to study this manual, and to practice with the NEVCO 

DISPLAY DIRECTOR Software. 

 

If you ever have any questions or comments, please call or email us. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

NEVCO, Inc. 

301 East Harris Avenue 

Greenville, IL 62246-2151 USA 

USA TOLL-FREE 800-851-4040 

CANADA TOLL-FREE 800-461-8550 

International Telephone: +1-618-664-0360 

Website: www.nevco.com 

Email: info@nevco.com 
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 DISPLAY DIRECTOR MANUAL INTRODUCTION

1.1 INTRODUCTION 

Welcome to Display Director, a content management software for your LED Video Display. 

Display Director is designed to have an unintimidating, intuitive user interface and provide a 

powerful in-game tool by allowing control of your game day operations. Display Director allows 

your system to easily display statistics, headshots, graphics, animations, ads, and more.  

 

1.2 SET UP 

Following is the general set up of Display Director. The diagrams show how it is set up and 

connected to the rest of your system for a few different configurations and options. 

 

Video Switcher/Broadcast Integration Setup 

 
 

 

 
 

 



 

 

Display Director User Manual Display Director Version 3.5.2 6 

 
 

 

 

 

 
 



 

 

Display Director User Manual Display Director Version 3.5.2 7 

1.3 USER INTERFACE 

Illustrated below in Figure 1-1 is an overview of the Display Director User Interface. This user 

manual will explain in detail each of these features and their functions.  

 

 

 

1. Main Menu 

2. Main Toolbar 

3. Audio Controls 

4. Project Display Dropdown List 

5. Network Connection Indicator 

6. Display Preview 

7. Video Volume Control 

8. Live Video Control Panel 

9. Tab Page Controls 

10. Button Layout Grid 

11. Data Reader Status Panel 

12. Zone Layouts Control Panel 

13. Character Generator (CG) Overlays 

Control Panel 

14. Live Video Status Bar

 

 

Figure 1-1 
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 QUICK START

 

2.1 INTRODUCTION 

Quick Start explains the simple building blocks of operating Display Director. It is used to explain 

opening a new or existing project, adding or importing media, managing buttons, creating tabs, 

setting up a live video, and communication to the Display Client. 

 

Before getting started, ensure that you have the green license key seen in Figure 2-1. Make sure 

that you have it plugged into your computer with Display Director on it. The software will not open 

if this key is not inserted. If you have lost your key, you must contact Nevco Service Department 

and a new one must be ordered. 

 

 
Figure 2-1 

Now, to get started, you must open Display Director. Your computer will be setup as seen in 

Figure 2-2. You may click the Display Director Computer Icon, seen highlighted in Figure 2-2. 

 

 
Figure 2-2 
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When opening Display Director for the first time, there will be a box that pops up with a black 

background and it says “Nevco” on it. To get rid of this, you must double click it. Following are 

some common terms and concepts used with Display Director. 

 

When referring to “(Display) Director,” it is what can be seen in Figure 2-3. When referring to 

“(Display) Client,” it is what can be seen in Figure 2-4. Figure 2-4 is the software that actually runs 

on the video display and what is in the top left is exactly what the video display would show. The 

Director controls what is shown on the Client. 

 

There are two “modes” that Display Director can be in: “EDIT” or “DIRECTOR.” If you are in edit 

mode, red will be seen as the outline of your display as in Figure 2-5. Edit mode is where you will 

add all of your content to the project. If you are in director mode, green will be seen as in Figure 

2-6. Director mode is where you will be able to play the content that is already contained in your 

project. Director mode can also be called “live” mode. The icon highlighted in each of these 

images will allow you to toggle between edit and director mode. 

 

 
Figure 2-5 

 
Figure 2-6 

 

Figure 2-3 Figure 2-4 



 

 

Display Director User Manual Display Director Version 3.5.2 10 

Figure 2-7 shows the grid of squares contained in Display Director. The top square has content in 

it, and therefore is called a button. It is currently selected because it has a pink box around it. The 

other squares have no content in them. The green square is where your mouse hovers. If you 

selected (clicked on) an empty button, it would turn pink, showing it is now selected. 

You can adjust the brightness of your display(s) by going to the main menu, Displays > Adjust 

Brightness, as seen Figure 2-8. 

Figure 2-7 

Figure 2-8 
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2.2 CREATING A NEW PROJECT 

If the New Project Dialog shown in Figure 2-11 is not open in Display Director after opening, select 

File > New Project from the main menu, shown in Figure 2-9 or click on the Create New Project icon 

in the main toolbar, shown in Figure 2-10. If an existing project is open, you must first close it to open a 

new project. By default, when Display Director is started, it will have the most recent project already 

open.  

When creating a new project, the New Project Dialog is displayed, shown in Figure 2-11, with a 

listing of all available displays (or clients). If no displays are listed, verify that all display controllers 

(clients) are turned on and then click LOCATE DISPLAYS. All displays on the network will be 

discovered and added to the Available Displays list. Select the display or displays to be included in 

the project, enter a Project Name, and then click on CONTINUE.  

 

2.3 OPENING AN EXISTING PROJECT 

When opening Display Director, it will open to the last project that was worked on. To open an 

existing project, first close any other project. This is done by selecting File > Close Project. Now 

select File > Open Project, this will show all projects you have created and you can now select the 

project you would like to open and click OPEN. You may also select the Open an Existing Project 

icon on the main toolbar, just as was done for opening new projects.  

 

Figure 2-9 

Figure 2-10 

Figure 2-11 
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2.4 ADDING BUTTONS TO A PROJECT 

There are two ways to add buttons to the project: Add Button Media and Import Button Media. The 

Add Button Media option creates one button and adds a one or more media file(s) to that button. 

The Import Button Media option allows the selection of multiple media files and creates a button for 

each selected media file. When using Import Media, it will import multiple files into the one zone 

selected – only one zone can be imported at a time. When using the Import Media option, keep in 

mind how much space is available on the button grid layout. If too many files are trying to be 

imported, it will issue an error and will omit the last selected media files if the user continues the 

import. Sequence files cannot be added using the Import Button Media option.  

 

When adding media to a button, it can be added from any location on your computer, such as a 

flash drive or a network drive – simply just navigate to that location in the Windows file explorer 

dialog window that comes up when adding media to a button. When it is added to the button, the 

media will be copied into a central file location, C:/NEVCOFiles/Media. This is where every piece 

of media you upload or create will be located. This is important in case you would like to clean out 

old pieces of media. By default, when adding media to a button, Display Director will pull up this 

file location for you to browse. 

 

The C:/NEVCOFiles/Media folder should never have subfolders. This is due to the fact that when 

a piece of media is sent to play on the display, the Display Client will look for the media in this 

specific “Media” folder. If the media is not in this specific folder, it will not find the piece of media 

and therefore, will not play the media. It is okay to have a subfolder here if you do not intend to 

use any of the media in the subfolder. For example, you could organize the old files that are not 

used anymore in a subfolder – this would be helpful if you did not want to delete the old files, but 

wanted to make sure they will not be used on the display.  

 

2.5 ADD BUTTON MEDIA 

Make sure that you are in edit mode when adding a button to your 

project. Select the square in which you would like to place the media 

from the button layout grid. There are four methods to add a button using 

the Add Button Media option:  

• Select Button > Add from the main menu 

• Click on Add Button icon (green circle with a plus sign) from the 

main toolbar 

• Right click on the selected square and click Add in the right click 

menu 

• Double-click the square 

 

When adding a button, the Button Properties Dialog window will display 

as shown in Figure 2-12. The Button Properties Dialog can be expanded 

to show more options, shown in Figure 2-13. This can be done by 

clicking on the ADVANCED >> option.  
Figure 2-12 
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Figure 2-13 

 

1. Button Name Textbox 

2. Layout Add and Remove Options 

3. Button Color Selector 

4. Zone Media List Box 

5. Display Options Group Box 

6. Hide Zone Layout Checkbox 

7. Enabled Live Input Checkbox 

8. Hide CG (Character Generator) Overlay 

Checkbox 

9. CG Overlay Options Group Box 

10. Selected CG Overlay  

11. Add and Remove CG Overlay Options 

12. Audio Options Group Box 

13. Selected Audio File 

14. Add and Remove Audio Options 

15. Cancel Audio Checkbox 

16. Media Options Group Box 

17. Media File Name and Information 

18. Add Blank Display Option 

19. Add and Remove Media Options 

20. Advanced and Simple Toggle 

21. Save or Cancel Add Options 

 

 

Select the zone the media file will be displayed in from the zone media list box (4), then click on 

ADD (19) which will show an open file dialog in which you can select the media or sequence file 

you would like to add. Click on Open to add the file. The selected file's name will be shown in 

the file name textbox (17) and in the button name textbox (1). The button name shown can be 

changed to a different name if desired, but by default it will be named the same as the last piece 

of media that was selected for the button. 
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A layout is a way to split your display into multiple “zones.” The layout can be selected by 

clicking + LAYOUT (2) and clicking on the desired layout. When a layout is selected, the 

number of zones that are in that layout will display in the zone media list box (4). Layouts are 

created in the Layout Creator tool, which will be covered in section 5 of this manual. The layout 

will stay on the display until another layout is applied to the display, the hide layout option is 

selected (6), or the hide layout option is clicked (from the zone layouts control panel on the main 

screen). 

 

CG overlays are overlaid on top of the content on the display. A CG Overlay can be added to a 

button by clicking on the ADD option (11) in the CG Overlay Options group box (9), then select 

the overlay you would like to use. The name of the overlay selected will display in the selected 

overlay textbox (10). CG Overlays are created with the CG Overlay Creator explained in section 

4 of this manual. CG Overlays will stay on the display until another overlay is applied to the 

display, the hide layout option is selected (8), or the hide overlay option is clicked (from the CG 

overlays control panel on the main screen). 

 

The button color can be changed by clicking on the button color selector (3). Choose a color and 

click on OK. This can help organize buttons added to the project.  

 

For the media information (17), the length should not affect anything as the display will continue to 

play the last piece of media that the user told it to. The end type can be set to repeat (endless, until 

you do something to change it) or none, in which the media will freeze on the last frame. 

 

On systems with our audio features, an audio file can be added to the button using the advanced 

Button Properties Dialog. Click on ADD (14) in the Audio Options group box (12) which will show an 

open file dialog where you can select the audio file you would like to add. Click on Open to add 

the file. The name of the file will be displayed in the audio file name textbox (13). Audio can be set 

to have its own button or to be played with a media file. 

 

Audio files (.mp3, .wav, or .m4a) will continue to play over any button until either: it is stopped 

manually by the user (audio controls in the upper left hand corner of the main screen of Display 

Director) or another button with an audio file attached to it is selected. This is also similar for video 

files with embedded audio (.mp4, .mov, etc.) These videos will continue to play as long as the video 

file is visible on the display.  
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To finish all button additions, click on SAVE (21) and the button will be added to the button grid as 

shown in Figure 2-14. 

2.6 IMPORT BUTTON MEDIA 

The Import Button Media option can be used to import multiple media files all at once. Make sure that 

you are in edit mode when adding buttons to your project. Select the square in which you would like to 

start the button import from the button layout grid. The two methods to import media into buttons are as 

follows: 

• Select Button > Import Media from the main menu 

• Right click on the selected square and click on Import Media from the right click menu 

 

Now the Import Media Files Dialog window will display as shown in Figure 2-15. 

 

 

 

 

 

1. Button Color Selector 

2. Zone Media List Box 

3. Media Import Options 

4. Transition Dropdown Menu 

5. End Type Dropdown Menu 

6. Add Media Option 

7. Add Audio Option 

8. Create and Add Audio Playlist 

Options 

9. Import and Cancel Options 

 

 

         

 

            

 

Figure 2-14 

Figure 2-15 
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Select the zone the media files will be displayed in from the zone media list box (2). Only select one 

zone for each import you do. It will start the import either from the first button window or from the 

selected button window (left to right, top to bottom.) Click on ADD MEDIA (6), which will show an 

open file dialog in which you can select the media files you would like to add. Select multiple files 

by clicking the beginning and holding Shift, then clicking the end, to select files together. Or, 

hold down Ctrl and individually select files to be imported. The order you select the files is the 

order that they will import. Click on Open to add the files.  

 

Buttons will be named by the file name; if a different name is desired, button text can be edited 

individually after import. The buttons’ color can be changed by clicking on the button color 

selector (1). Choose a color and click on OK. This button color will be set to all of the media being 

imported. These buttons will not have a layout and therefore will show the last layout applied with 

the new button’s content in the zone that was selected. You can change the end type, just as 

described for the Add Button Media option. Leave the transition option as it is. Now you can click 

IMPORT (9), and for every media file you selected, a button will be created. 

 

The Import Media function can also be used to import multiple audio files or an audio playlist. To 

create an audio playlist using the Audio Playlist Creator tool, click “Create and Add Media Playlist” in 

the Import Media dialog or on the main menu on the Display Director main screen, Tools > Audio 

Playlist Creator. Playlists created with this tool will have the file extension of .apl. Audio and media 

cannot be added at the same time using the Import Media Dialog feature.  

 

After the new buttons have been added to Display Director using the Import Button Media, it will 

look similar to Figure 2-16. 

 

Figure 2-16 



 

 

Display Director User Manual Display Director Version 3.5.2 17 

2.7 EDIT, MOVE, AND DELETE BUTTONS 

To edit, move, or delete existing buttons, Display Director must be in edit mode first. Then you can 

select the button in which you would like to edit. Button editing can be performed using one of the four 

methods: 

• Select Button > Edit from the main menu, as shown in Figure 2-17 

• Click on the Edit Button icon in the main toolbar, as shown in Figure 2-18 

• Right click on the selected button and select Edit, as shown in Figure 2-19Figure 2-19 

• Double click on the selected button 

The Button Properties Dialog will be displayed as seen before in Figure 2-12 or Figure 2-13 for 

advanced editing. Select what zone you would like to edit, click on the EDIT option to change the 

selected attached media, make all other desired changes as described before, and then click 

SAVE to save the updated button. 

 

Button functions of cut, copy, and paste can be performed using one of the four methods: 

• Select the button and on the main menu select Button > (desired action) 

• Click on the desired action’s icon in the main toolbar 

• Right click on the button window being edited and select the desired action 

• Select a button to edit and use the key shortcuts to perform the desired action: 

       Cut: Ctrl + X, Copy: Ctrl + C, Paste: Ctrl + V 

 

To move a button, select it and cut or copy it using one of the methods described above, then 

paste it to the desired new location. If the cut option is selected, the button will be removed from 

the previous location in button layout grid. If the copy option is used, the button will remain in the 

button layout grid where it was copied from and will also be in the new location that it is pasted in. 

Any undesired button can be deleted. 

 

Deleting a button is very similar to adding a button. Select the button which you would like to remove, and 

then there are four ways to delete it:  

• Select Button > Delete from the main menu 

• Click on Delete Button icon (red circle with a minus sign) from the main toolbar 

• Right click on the selected button window and select Delete from the right click menu 

• Hit the Delete key on your keyboard 

Figure 2-18 

Figure 2-19 
Figure 2-17 
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2.8 CREATING TABS 

Tabs are useful for organizing many different sets of buttons in one project. To add a tab to your 

project, select Tab > Add or click on the Add a Tab icon on the main toolbar. A dialog box will 

open where you can enter the name of the new tab and then click on SAVE to add the tab. To 

access the tab, simply click on it. This will change the grid of buttons to that tab’s content. 

 

There are other tab options displayed on the main toolbar and the main menu that can be used to 

insert, edit, or delete tabs. Inserting a tab will insert the new tab exactly where the currently 

selected tab is located. Editing the tab will allow you to rename the tab. Deleting the tab will delete 

the tab and all of its content. There is also one option located on the main toolbar, Tab > Clear 

Current Tab that allows you delete all of the buttons in the currently selected tab.   

 

2.9 SETTING UP A LIVE VIDEO STREAM 

Make sure that your live video equipment is setup and connected to the Display Director system. 

To start setting up your live video for Display Director, open up the Configure Live Source window 

by selecting Tools > Video Capture Setup and then a window similar to Figure 2-20 will open. If 

you are in multiple mode (described in section 2.12), go to the Client computer and select the “VID 

CAPTURE” option on the Display Client to get to the Configure Live Source window.  

 

Now you will need to select the correct options for your setup. The following will use the example 

as shown in Figure 2-20. This is a computer with the Blackmagic Design Decklink Studio 4K 

capture card installed. The first option seen here is simply selecting the video source. So for this 

example, the “DeckLink Studio 4K” is selected. In this list, you may see anything that is connected 

to the computer such as capture cards, webcams, or screen capture programs. 

 

 

 

 

Figure 2-20 
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The next option that is selected is the “line” – this is where the video is coming from. In other 

words, there will be multiple ways that your video can be input into your computer and this will 

need to be selected from this dropdown list. Options include HDMI, SDI, Component, Composite, 

or S-Video. It may also include what the input for the audio is as well.  

 

Lastly for the video device setup, there will be a Format dropdown list. This will list different 

formats that the video can be in. Options include: NTSC options, HD 720-60p, HD 1080i and 

1080p with different refresh rates, and UHD 4k with different refresh rates. This should be 

selected according to your video input.  

 

 

After all of the video options are selected, there are now audio options that can be selected. The 

Audio dropdown list will show the options that you will have for audio, including from a capture 

card, such as the Blackmagic Decklink. Microphones would also show up here as an option. 

 

Next is an External dropdown box – this will be used if you have an external audio source and will 

be similar to the “Audio” dropdown box.  

 

Now you can select the format that the audio will be in or you can leave it to set to auto. This will 

have details such as the frequency, number of channels, and number of bits.  

 

Now there will be one last dropdown box that will give you the option to change the video output 

format. Choose your desired output format or leave it to set to auto.  

 

When you have all of the options selected that match your system, ensure that your video capture 

system is setup and turned on. Now you can click “Init Device” and your stream should come up 

on the right side of this dialog box in the preview window. Now click “Save and Close” and your 

system is ready to go live.  
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2.10 LIVE VIDEO STATUS BAR 

There is a status bar for the live video status on the Display Director main screen as seen in Figure 

2-21. It will have the status of each display that is set up for live video. If the live video feed is set 

up properly, it will display in black text something like “Live Signal: OK, State: Running” and 

alternatively, if it is not working as expected, it will display in red text and will list if it is getting any 

signal or not. For Figure 2-21, the live video camera was simply turned off and therefore, it was not 

getting a live video signal. If the user hovers the mouse over the client’s live video status, it will 

display more information about the live video setup such as the video input device and the video 

format.   

 

This is a helpful visual cue to warn the operator that something may need to be fixed before game 

day. The status will change real time, so that if something were to come unplugged or the camera 

was not turned on, the user can see that feedback immediately and know that someone should 

take a look at the live video setup to ensure that Display Director can get the live video. See our 

troubleshooting guide at the end of the manual in section 10 for tips on troubleshooting a live 

video setup that is not operating as expected.  

 

2.11 DISPLAYING A LIVE VIDEO STREAM 

There are multiple ways to make the display go live. One of the ways is to find the live video 

control panel on the right of the Display Director main screen, ensure that the display you want to 

display your live stream is selected, and then click “Go Live!” or hit the F1 hotkey.  

 

The other option to launch the live stream is to create a button that is just made for going live. You 

can then assign layouts and overlays to it, just like any other button. When you are creating the 

button, in the advanced options, you will see a checkbox with “Enable Live Input” – check this box. 

Now anytime the button is selected, the video display will go live. This option can be seen in Figure 

2-13 and is the checkbox with the “7” label. 

 

Figure 2-21 
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2.12 SENDING MEDIA TO DISPLAY CLIENT 

Display Director can run in single or multiple mode. Systems running in single mode do not have 

to send media files to the Display Client and can skip this step. To determine which mode Display 

Director is running in go to the main menu and then select Help > About, as shown in Figure 2-22. The 

mode will be listed on the left side of the About Display Director dialog window, as shown circled in 

red in Figure 2-23. See in Figure 2-23, there is also the version number listed. This is helpful 

information for our Service Department in the case you call in with any issues.  

For systems running in multiple mode, files must be sent to the Display Client to operate correctly. 

The time required to complete the send process is determined by the number of buttons 

contained in the project and by the number of buttons added to the project since a previous send. 

For larger projects, this process should be done well in advance of any scheduled event. As with 

most features in Display Director, there are two methods to send files. The first method is to 

click on the Displays > Send Files in the main menu, shown in Figure 2-24. The second method is to 

click the Send Files icon on the main toolbar, shown in Figure 2-25. 

 

The send files options will be disabled (grayed out) if Display Director is connected to the Display 

Client in director mode. To enable the menu item and toolbar icon, change Display Director to edit 

mode. Click on Displays > Disconnect from the main menu or refer to Figure 2-5 and Figure 2-6 for 

the toolbar Connect icon. 

 

 

Figure 2-22 

Figure 2-23 

Figure 2-24 Figure 2-25 
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After clicking the Send Files icon or selecting Display > Send Files from the main menu, the media 

files will be sent to the Display Client. During the send process, the Send File Progress Dialog will 

be displayed, shown in Figure 2-26. After the send file process is completed, it will close 

automatically and the files should now be available to play on the Display Client. 

 

If the user forgets to send files before attempting to play media, they will be warned when 

switching to director mode. It will tell them how many files have not been sent to the client and will 

ask if you would like to send the files. If the files are not sent before attempting to play, they will 

simply not play on the display.  

 

Select Displays > Connect from the main menu or click on the Connect icon in the toolbar, 

shown in Figure 2-5 and Figure 2-6. This icon and borders will change from red to green meaning 

Display Director is connected to Display Client.  

 

With Display Director connected to the Display Client, click any of the buttons and the running 

media will be shown in the display preview, where Pepsi is shown below in Figure 2-27. The 

content in the display window will also be shown on the display (client).  

Figure 2-26 

Figure 2-27 
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 MEDIA SEQUENCER 
 

3.1 INTRODUCTION TO MEDIA SEQUENCER 

Media Sequencer is an application that can be used to create a sequential list of media files, sort 

of like a slideshow. Sequences can be comprised of both image files (.jpg, .png, .bmp, etc.) and/or 

video files (.avi, .wmv, .mov, .mpg, .mp4, etc.). This can be used in many different ways, including: 

advertising, slideshows, commercials, highlights, and much more. Sequences should be made in 

advance of game time. Sequences are not project specific and can be accessed by any project 

that is opened in Display Director.  

 

3.2 MEDIA SEQUENCER USER INTERFACE 

 
Figure 3-1 

1. Main Menu 

2. Main Toolbar 

3. Sequence Preview Window 

4. Sequence File List 

5. Duration Preview 

6. File Preview 

7. Transitions Between Media 

8. Media Duration Option

 

3.3 CREATING A MEDIA SEQUENCE 

Open Media Sequencer application from the Display Director main menu by selecting Tools > 

Media Sequencer, shown in Figure 3-2. 

Figure 3-2 
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Create a new sequence by clicking on the New icon on the main toolbar, shown in Figure 3-3, or by 

selecting File > New in the Media Sequencer application on the main menu, shown in Figure 3-4. 

 

Choose the display that you would like to create the sequence for from the Display Dialog that 

appears and then select OK, shown in Figure 3.5. This is important for the sizing of the sequence. 

It is possible that if you create a sequence for one display and then try to display it on a different 

sized display, the sequence will not work.  

 

 
Figure 3-5 

 

3.4 ADDING MEDIA TO SEQUENCE 

Now that a new media sequence is open, it is ready for you to add media files. To add media, click 

on the Add icon in the main toolbar, shown in Figure 3-6, or by selecting Media > Add from the main 

menu, shown in Figure 3-7. 

Figure 3-4 

Figure 3-3 

Figure 3-6 

Figure 3-7 
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A Windows open file dialog will appear. Use this dialog to search for and select the media you 

would like to add. Multiple files can be selected and added to the sequence at once. Click Open to 

add the file(s). The selected media will appear in the file list menu and the bottom preview 

windows, as seen in Figure 3-8. 

To save a media sequence, select File > Save, or click the Save icon on the main toolbar. A Save 

File dialog window will appear, seen in Figure 3-9. Give the sequence a name in the filename box 

and click the SAVE option. 

 

3.5 PREVIEWING A MEDIA SEQUENCE 

After adding media to the sequencer, the sequence can be previewed by clicking on the Preview 

Sequence icon in the main toolbar shown in Figure 3-10, or by selecting Tools > Preview from the 

main menu. 

Figure 3-8 

Figure 3-9 

Figure 3-10 
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The media files will be shown in the sequence preview window, as seen in Figure 3-11. The files 

will play in the set order, each with their own duration. The file transitions will also be displayed 

while running the sequence.  

Click on the Stop Sequence icon in the toolbar, seen in Figure 3-12, or select Tools > Stop Preview 

from the main menu, to stop the sequence preview. The sequence cannot be edited or saved while 

previewing, so it must be stopped before editing. You may now edit by deleting, rearranging, and 

adding media. You may also add transitions and change duration times. Media can be rearranged 

by clicking and dragging the thumbnails on the bottom panel shown in Figure 3-11. 

 

For optimal performance, it is recommended that for each sequence created, it remain at or under 

20 files. Media Sequencer will allow users to go over this recommendation if needed.  

3.6 ADDING A MEDIA SEQUENCE TO A BUTTON 

The sequence you just created is automatically saved into the C:\NEVCOFiles\Media folder on 

your computer. The sequence file will be created with the file extension of .spq. You can now add 

the sequence file to a button as explained in section 2.5. Remember that a sequence cannot be 

added by the “Import Button Media” option.  

 

If a sequence is added to a button, and then the sequence is updated, it will automatically update in 

the previously created button.  

 

When a sequence is playing on the display, and a different animation is selected, Display Director will 

hold on to the timestamp in which the sequence was halted. This means that the next time this 

sequence is selected, it will resume where it left off. Only one sequence’s timestamp is held in 

memory, so this function will only work for the most recently interrupted sequence.  

Figure 3-11 

Figure 3-12 
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 CHARACTER GENERATOR OVERLAY CREATOR

 

4.1 INTRODUCTION TO CG OVERLAY CREATOR 

CG Overlay Creator an application that is used to create overlays for buttons. Overlays are 

made to display over top of all other content. Overlays can include images, conditional images, 

permanent text, and editable text. Overlays are added to buttons in the in the Button Properties 

dialog window in the advanced portion, as displayed in Figure 2-13. Overlays can also be used 

for a Virtual Scoreboard, or VSB, to show on the video display. Overlays are not project specific 

and can be accessed by any project that is opened in Display Director. 

 

4.2 CG OVERLAY CREATOR USER INTERFACE 

Open CG Overly Creator by selecting Tools > CG Overlay Creator from the main menu in 

Display Director. This will pull up the CG Overlay Creator application and it should look 

something like Figure 4-1. The black box seen here is the preview for your message center and 

can be zoomed with the Tools option on the main menu. To move, resize, and rearrange items, 

the main toolbar can be used.  

 

1. Add Image    2. Add Pitch Speed Image    3. Add Text    4. Add Data Item (Dynamic Text) 

 

4.3 CREATING A NEW OVERLAY 

To open a new overlay, select File > New or click on the New icon on the main toolbar. Now a 

window will open for you to select the display that you would like to use the overlay on, name 

the overlay, and click OK. Your display preview should now show up. Now you can use the side 

toolbar seen in Figure 4-1 to add various objects to your overlay. If an overlay is used on a 

display that it was not created for, it has the potential to not work. 

Figure 4-1 
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4.4 CREATING DATA ITEMS AND VIRTUAL SCOREBOARD ELEMENTS 

To add dynamic text (you can edit in game), click on Add a Data Item (4) icon and then a dialog 

window, shown in Figure 4-2, will show up. Set the Data Properties dropdown lists as shown in 

Figure 4-2, and change Field number as necessary. Click on ACCEPT to add this item to the 

overlay. You can also change the Data Properties dropdown lists to include virtual scoring items 

– this is explained later in this section.  

 

To finish your overlay creation, save your layout by selecting File > Save from the main menu or 

click on the Save icon on the main toolbar. Verify the name of your overlay, then click SAVE. 

Overlays will stay on the display until another overlay is applied to the display, the hide layout 

option is selected on a button, or the hide overlay option is clicked (from the CG overlays control 

panel on the main screen in Display Director). When an overlay is completed, it can now be 

added to a button as described in the section 2.5. 

 

 

Now to change the dynamic text in game, click on USER DATA option in the CG overlays 

control panel on the Display Director main screen or go to the main menu and select Tools > 

User Data Entry…, or hit the hotkey, F3, on your keyboard. This will open the dialog window to 

change the dynamic text fields, shown in Figure 4-3 on the following page. Select the field you 

would like to change, make your update, and then click UPDATE and CLOSE to exit. Your 

changes should be saved and reflected as the item on the overlay will change. This is a neat 

feature that could be used for a 50/50 raffle or for displaying the next home game date.  

 

Figure 4-2 
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In order to create a Virtual Scoreboard overlay, you will need to create each element separately 

and then you can arrange them in the way that you prefer. In order to add an element to the 

scoreboard overlay, click on the Insert Data Item (4) icon and this will bring up the Insert Data 

Object dialog window. In this window, to the right, you will see the Data Properties group box, 

similar to before as in Figure 4-2. 

 

For the Data Source of the object, there will be two options for virtual scoring: NEVCO and 

StatCrew. If you are using StatCrew, select StatCrew. Right now, Display Director supports the 

following sports for StatCrew: baseball game and season data, basketball, football, ice hockey, 

lacrosse, soccer, and volleyball. Everything else will be under the “NEVCO” data source. 

“Everything else” includes all MPC (Nevco specific) data, FinishLynx track, HyTek track, and 

FlashTiming track. The MPC data that Display Director supports are as follows: basketball, 

basketball stats, baseball, football, volleyball, lacrosse, soccer, wrestling, hockey, pitch speed, 

and datetime. Pitch speed data is to be obtained with the Stalker radar gun interface. DateTime 

objects are various configurations of date, time or both together. These will read from the 

computer, so make sure that the date and the time of your computer is accurate.  

 

The dropdown boxes after the Data Source is selected will change depending on what you 

choose. The Type dropdown will include the data listed above as supported, so you would 

choose what suits your needs and then the Table dropdown will change accordingly.  

 

Again, the Table dropdown will update based on what you select as the Type. Usually, this will 

either be a sport or if you have already selected a sport, then this will be a data type; For 

example, if you have selected the Data Source as StatCrew and the Type as Soccer, then the 

Table field will have the following options: period1h, period1v, period2h, period2v, playerh, 

playerv, teamh, and teamv. Each of these selections will bring up different options in the Data 

Field dropdown.  

 

Figure 4-3 
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In order to create a DateTime object, the Data Source should be “NEVCO,” the Type should be 

“VSB,” and the Table should be “DateTime.” This will populate the Data Field options to multiple 

choices for date, time, or both together.  

 

The Data Field option will include specific data items based upon the fields selected above. 

Continuing the example presented earlier, let us say that with the Data Source as StatCrew and 

Type as Soccer, you select the Table as teamh (which means “Home Team”). Now the data that 

will come up in the Data Field dropdown will be as follows: id, name, code, record, score, shots, 

saves, fouls. Selecting the saves option will add a data element to your overlay that will change 

dynamically with the home saves that are set in game. You can change the look, size, and 

position of each data element. Building from this example, you can now create your virtual 

scoreboard.  

 

Keep in mind that in addition to your scoreboard elements, you can also add images to your 

overlay, such as your school mascot. Also, another neat trick for a virtual scoreboard is that 

instead of adding text labels of “home” and “guest,” you can add your team mascot’s name, 

such as “Eagles” and for the guest’s team name, you can select a user data item (explained 

above) that you can change each time there is a different away team, instead of making a new 

overlay.  

 

4.5 CREATING A PITCH SPEED IMAGE 

Display Director supports displaying pitch speed; the way that this works is that when the pitch 

is thrown, a Stalker radar gun is used to obtain the speed of the pitch. When there is a pitch 

speed registered, then it can show up virtually on your video display through Display Director, 

on an overlay. The pitch speed will remain for a set number of seconds after the pitch. This 

duration can be changed in the Stalker radar gun’s settings – Display Director simply reads the 

data that is output by the Stalker radar gun.  

4.5.1 Hardware connections 

Connect hardware as described in the pitch speed interface manual (135-0141.PDF). 

Connect receiver coax output to VSBI. 
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4.5.2 Decryptor Setup 

On the Display Director PC Setup a decryptor input for 

the incoming serial data.  

 

 

 

 

 

 

 

 

 

 

 

4.5.3 DataReader Setup 

In Display Director setup a 

datareader for that decryptor 

output: 
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4.5.4 Pitch Speed CG Overlay 

Create a CG with pitchspeed data and use the pitch speed icon to add graphics you wish to appear and 

disappear along with the pitch speed when the ball is pitched. 
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 LAYOUT CREATOR 
 

5.1 INTRODUCTION TO LAYOUT CREATOR 

Layout Creator is an application that is used to create button layouts, each layout having one or 

multiple zones. This means that multiple media can be contained in one button and displayed at 

the same time on the video display. For example, you could have a live video on one half of the 

screen and player statistics on the other half. Layouts are not project specific and can be 

accessed by any project that is opened in Display Director. 

 

A good suggestion for using layouts is to create one main layout button that you will use 

primarily on your display. Then create buttons without layouts and insert media in the different 

zones where you would like to display new images. This way you can change each zone of your 

default layout individually. When a button is selected that only has media in one zone, it will only 

change the media in that one zone (other zones will remain with previously selected media).  

 

Layouts should be added to a button when it is desired to look exactly that way every time it is 

played. For example, you may want the American flag animation to be shown full screen any 

time it is selected, so you add a full screen layout to the same button.  

 

If a layout is not set, it will be set to default; this will make the layout full screen unless there are 

other layouts previously selected. When switching buttons in director mode, if you are switching 

from a button with a set layout to a button without one, also called default, the second button will 

display in the same layout as the previous button.  

 

The layout will stay on the display until another layout is applied to the display, the hide layout 

option is selected in the settings of creating a button, or the hide layout option is clicked (from 

the zone layouts control panel on the main screen). Hiding the layout will make zone 1 full 

screen. 

 

Adding a layout to a button is described in section 2.5. 
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5.2 LAYOUT CREATOR USER INTERFACE 

Open Layout Creator by selecting Tools > Layout Creator from the main menu on Display 

Director’s main screen. This will pull up the Layout Creator application and it should look similar 

to Figure 5-1, once you have selected a layout.  

 

 
Figure 5-1 

5.3 CREATING A NEW LAYOUT 

To open a new layout, select File > New or click on the New icon on the main toolbar. Now the 

Select Template dialog window, shown in Figure 5-2, is open. This dialog window shows a few 

layout templates created for you. Select the template you would like. Make sure that you also 

select the display that you wish to create the layout for. If a layout is applied to a display that it 

was not made for, it is possible that it will not display correctly. Click on OK to open the layout 

template.  

 

 

Figure 5-2 
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At this point you can either save the layout as is or you can edit this layout to your own liking by 

using the left side toolbar and preview window. Zones can be added, deleted, resized, and 

moved.  

 

If there is an area on the preview window which is left without a zone, then no content can be 

added in this area. This means that no media can be displayed there, but an overlay will still 

overlay on top of this area. An example where this could be useful would be if you had StatCrew 

stats being displayed on one side of your video display, you could make it so that there is a 

layout that can be displayed with these stats so that no media can ever be behind the stats and 

the stats can be read easily. 

 

The zone with the multicolored bars in Figure 5-1 is the live zone. When creating a layout, the 

live zone is set up to be the only one the plays audio, so there will be no audio overlap if you 

insert multiple pieces of media with audio. The live zone also denotes where your live stream 

will display when it is selected to “Go Live” from the live video control panel on the Display 

Director main screen. The live zone can be changed with the toolbar on the right side.  

 

The maximum number of zones that can be added to a layout is 8. However, this limit is 

sometimes set to a smaller number based on the size of the video display. If the display is 

smaller, then it would look very crowed and busy with 8 zones. 

 

To finish your layout creation, save your layout by selecting File > Save or click on the Save 

icon on the main toolbar. Name your layout, then click SAVE. 
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 DATA READER (VIRTUAL SCORING) 
 

6.1 INTRODUCTION TO DYNAMIC DATA SOURCES 

A dynamic data source is an XML feed into Display Director from another software package or 

device. An XML file can be interpreted by Display Director and will automatically update the data 

from the XML feed on your video display via a CG overlay. This is useful for the implementation 

of virtual scoring on an LED display.  

 

There will need to be separate data readers for each data source that needs to be read by 

Display Director.  

 

6.2 CREATING A DYNAMIC DATA SOURCE 

Data Reader is a mechanism used by Display Director to read this dynamic XML data. The XML 

data is changing as the game data changes and is updated. In order to point data reader to an 

XML file, go to the main menu and click on Tools > Data Reader Setup. On the main menu of 

Data Reader, click on Edit, then Add Data Input. The window seen in Figure 6.1 will show up. In 

the background is the Data Reader window. 

Figure 6-1 

The name of your display that will be hosting this data should be listed in “Display.” If it is not, 

then change the name of the display in text box to match where you want the data. The “Data 

Source” is the type of data being read, this list can be seen in Figure 6-1. The data sources 

include: NEVCO, multiple StatCrew sports, PitchSpeed, and DateTime.  

 

A NEVCO data source can be multiple things. NEVCO data sources include NEVCO 

scoreboard data files (MPC), FinishLynx, and HyTek. (FinishLynx and HyTek are third party 

companies that Display Director can read data from to display on your scoreboard.) These are 

found under “NEVCO” because the Nevco Decryptor software is used to create a readable 

version of the data for Display Director.  
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A StatCrew data source is used for any data that is from StatCrew. (StatCrew is a third party 

company that Display Director can read data from to display on your scoreboard.) The file is 

already readable by Display Director and does not need to go through Nevco Decryptor. 

Multiple sports are currently supported by Display Director: Volleyball, Basketball, Baseball 

(singular game and season data), Lacrosse, Soccer, Football, and Ice Hockey.  

 

The DateTime data source is pulled from the system that Display Director is running on. It will 

pull the date and the time so that this data can be displayed on the scoreboard along with other 

data.  

 

The PitchSpeed data source will pull data from a Stalker Radar gun interface. (Stalker Radar is 

a third party company that Display Director can read data from to display on your scoreboard.) 

This data source will be an output of Nevco Decryptor.  

 

Now the “Browse for Source File” option can be selected in order to find the file that Display 

Director will read from. This will be where the StatCrew dumps its output files or it will be where 

Decryptor is set to put the output files. DateTime will not need a source file to be selected. 

 

Enter the “File Path” with respect to the computer that is reading the data. For example, if the 

Display Client Computer has the data in C:\NEVCOFiles\StatCrew\game.xml, then you may 

enter that path here. If the file actually resides on another computer in a local network, then you 

should enter the path \\COMPUTER\NEVCOFiles\StatCrew\game.xml. Replace “COMPUTER” 

with the computer name or IP address that hosts the file. If you are running a multiple system, 

then Display Director will open to the client computer’s file path. You may test this path by 

copying and pasting it into Windows File Explorer address bar and confirming the file that you 

want to read opens. Keep in mind that Decryptor’s output file is Display Director’s input file.  

Now there are a few options that can be selected related to when the file updates and what the 

status lights are going to indicate. These are indicated in Figure 6-2. The Data File Status 

Indicator Settings are related to the Status Indicator Panel shown in Figure 6-3, which can be 

found on the main Display Director User Interface. This Indicator Panel will display status 

indicators that will show whether Display Director is getting new information or not. The Status 

Monitor Interval setting will determine how often that data reader is getting checked.  

 

Figure 6-2 

Figure 6-3 



 

 

Display Director User Manual Display Director Version 3.5.2 38 

The Data Properties settings will determine when Display Director will read information from the 

selected file. The options are for “On File Update” or “Timed”. There is also an option for “None” 

if you desire the data reader to never update. “On File Update” will update the data in Display 

Director as soon as the source file is updated. “Timed” will update the data in Display Director 

on an interval that can be chosen.  

 

In the case that one of the data readers is indicating that it is not getting new data, there are a 

few steps that the user can take to ensure that this is fixed: 

- First, make sure that the source of the data is actually turned on and outputting data to 

the Display Director computer. For example, if you are reading data from an MPC 

controller, this will need to be turned on so that there is active data coming in to be read. 

- If this is data source that requires Nevco Decryptor, then ensure that Decryptor itself is 

operating correctly. This can be done by monitoring the output file of Decryptor, ensuring 

that it is changing. Sources that require Nevco Decryptor include: scoreboard data files 

(MPC), FinishLynx, HyTek, and Stalker Rader setups.  

- It could be that the Status Monitor Interval has been surpassed. For example, if there is 

a StatCrew file that is has not been updated in over an hour (default Status Monitor 

Interval for StatCrew), then the status indicator will turn red to indicate it is not getting 

new data. This means that everything is still setup properly, but the file has not updated. 

This should be fixed by pushing an update to the StatCrew file.  

- If Decryptor is working and the Status Monitor Interval has not been surpassed, then the 

other option is to double check that the data reader’s source file is accurate. This can be 

done by opening the Data Reader Setup and then selecting the troublesome data 

source, and clicking “Edit Data Input”. Here, you can check that the “File Path” is correct.  

 

Keep in mind that you will need to create a data reader for each type of data you want to read. 

For example, if you were reading MPC data with StatCrew data, and you wanted DateTime on 

there as well; this means that you will need to set up three separate data readers. 

 

For MPC data readers, these should only be setup once for all of your sports, provided you are 

not using legacy scoreboards. For example, there should only be one data reader for a 2700 

scoreboard that displays Basketball, Volleyball, and Wrestling. Note that for this setup 

mentioned to work, Decryptor 2.0 and up will be needed.  

 

Once all of these data readers are created, they will automatically start themselves and will 

update the data in Display Director immediately. There should be no further maintenance of the 

data readers themselves as they will start up on creation, when Display Director is opened, and 

when the user changes to “Live Mode.” 
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 CONTENT PLAY LOG 

 

7.1 VIEWING A PLAY LOG REPORT 

A play log is a log of all of the content that was played on your video display, it will list the file 

name, start time, duration, and other details. To view a play log, select Tools > Play Log… from 

the main menu on the Display Director main screen. This will open the dialog window seen in 

Figure 7-1. Now you can filter with the dropdown box by viewing all displays’ reports together or 

just selecting one display at a time. There will be a separate play log for each day, as seen below. 

To view it, simply check the checkbox next to the play log(s) you would like to view and then click 

LOAD PLAY LOG. You can view multiple play logs together, at the same time.  

 

 
Figure 7-1 

 

7.2 EXPORTING TO A FILE 

You may wish to export this play log to a file in order to share as proof to advertisers that 

their content was played on your video display. This can be used as a sort of receipt. Click 

EXPORT TO FILE and this will open a dialog save the playlog as a CSV (comma separated 

value) file. A CSV file can be opened by a simple text editor or by Microsoft Excel.  

 

Select CLOSE when you are finished viewing and exporting play log files.  
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 DISPLAY CLIENT 
 

8.1 CLIENT CONTROL PANEL 

Figure 8-1 below is of the Display Client. There are multiple controls that can be found here. If your 

system is a single system setup, then you might not see as many controls as they will be located 

in the director user interface.  

 

Figure 8-1 

Bright Adjust – This slider can be used to adjust the brightness of the video display 

 Reset Bright – This button will reset the brightness level to the default value (50%) 

Contrast Adjust – This slider can be used to adjust the contrast of the video display 

 Reset Contrast – This button will reset the contrast level to the default value (50%) 

Stop Life Monitor – Life monitor is system that keeps your client open, so that when your  

computer is rebooted or if the client gets closed, it will stay open. However, if you need to 

close the client, you can click this button and then the exit button to close it. Note that you 

will need to reopen it for your video display to show any content.   

Refresh – This will close and reopen your display client. This will reset your video display to black. 

Fullscreen – This can be used to make the display client go full screen on your computer monitor.  

Double click on the full screen display to reset it back to your settings. 

Properties – This is where you can change the pixel matrix and other settings of the video  

display. It is not recommended that you change these settings without talking to the Nevco 

service team. This control is located in the director on a single system setup. 

Exit – This will exit your display client. Note that no content will show on your video display  

without reopening the display client. 

VSB Props – This button will open settings where you can change the way that indicators (such  

as possession, end of period, or bonus) look on your virtual scoreboard (VSB).  

Vid Capture – This option will allow you to setup your live video feed. This will be in the director  

settings for a single system setup.  
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 CONTENT GUIDELINES 
 

9.1 CONTENT CREATION GUIDELINES 

Designing content for digital media is different than designing content for a printed copy; different 

rules apply for creating an effective message. 

 

Make Text Large 

• Outdoor displays should be simple, clear, and easy to read 

Bold Text – Making Your Display More Legible 

• Use both upper and lower case letters 

• Use sans-serif fonts – these provide the best readability 

• From a distance, thin lines begin to fade and very heavy fonts blur together 

• Add a dark, thick line around text to separate it from the background 

Convey ONE Message or Idea at a Time – Less is More! 

• Keep messages or images to a minimum 

• Convey ONE thought to your target audience 

Short and Sweet – Keep the Words Short for Faster Comprehension 

• Use no more than ten words on a billboard, including logo and product tag line 

• It is recommended that seven or fewer words are used for the headline 

Use Bright, Bold Hues and Limit White Backgrounds 

• Use the primary colors – red, yellow, and blue 

• Do NOT use complimentary colors, like orange and green, together 

• Use contrasting color combinations – best for viewing from far distances 

Chose Images Carefully 

• It is recommended that three or less visual images are used 

Example: one image, one logo, and one headline 

• Use images that correspond to the size (and aspect ratio) of your display for 

optimal performance 

• If occasional delays, lock-ups, or crashing are experienced, try resizing your media 

to be smaller 

No White Space 

• Outdoor digital displays are NOT like printed media; what looks good on paper may not 

be a good digital display – a full white screen may illuminate the stadium more than the 

lighting and be distracting to players and fans 
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9.2 ACCEPTED MEDIA TYPES 

Display Director uses certain video codecs for video playback. It is important that you know what 

video codecs are supported. A non-supported codec may not be accepted by Display Director or 

could lock up the display output. 

 

File Format Codec name 

.avi Xvid, MPEG-4, DivX, ffdshow 

.mov H.264, Sorensen 3, Animation 

.wmv Windows Media Video 9 

.mp4 / .mpg MPEG-4 Video File 

 

Image File Types: .jpg, .png, .bmp 

Video File Types: .avi, .mov, .wmv, .mp4, .mpg, .spq, .gif 

Audio File Types: .mp3, .m4a, .wav, .apl 

9.3 RECOMMENDED FILE SIZES 

 

File Resolution: When creating content, you will experience the best performance when 

your images and/or videos are the exact pixel matrix of your video display. File resolutions 

above 1920x1080 are not supported.  

 

File Size: Total file size should not exceed multiple gigabytes (GB).    

 

9.4 ACCEPTED VIDEO INPUT FORMATS 

The following video formats are accepted by Display Director by means of the hardware interfaces 

listed. 

 

Video Formats: 

HD Video Standards 

720p50, 720p59.94, 720p60 

1080p24, 1080p25, 1080p29.97, 1080p30, 1080p50, 1080p59.94, 1080p60 

1080PsF23.98, 1080PsF24, 1080PsF25, 1080PsF29.97, 1080PsF30 

1080i50, 1080i59.94, 1080i60 

 

Hardware Interfaces: 

SDI Video Inputs 

1 x 10-bit SD/HD/2K/4K - Supports 6G 4:2:2 and 3G 4:4:4 

HDMI Video Inputs 

1 x HDMI type A connector 
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 TROUBLESHOOTING GUIDE 

 

10.1   INTRODUCTION TO THE TROUBLESHOOTING GUIDE 

This troubleshooting guide is meant to help the user through some of the most common issues 

experienced in operation. Please check this guide if you are having problems. The issues covered 

in this guide assume that the hardware is connected properly. If the solution to your problem does 

not fix your issue, all of the solutions listed here are good checks to ensure your system is set up 

correctly. If your problem is not included in this guide, please contact our service department. 

 

This troubleshooting guide includes information on the nonoperation of single and multiple system 

setups and the nonoperation of virtual scoreboards. To check what system setup (single or multiple) 

you are running, refer to section 2.12. 

 

Also, be sure to refer to section 2.1 to clarify the use of “director” and “client” keywords used in this 

troubleshooting guide. This guide also assumes that you familiar with the rest of the user manual.  

 

10.1 SINGLE DISPLAY SYSTEM 

A single display is one that only runs on one computer, meaning the director and the client are on 

the same computer. Following are common problems and solutions that can occur within a single 

display system.  

10.1.1 Problem: The preview window does not match the display, the message center 

doesn’t reflect the button presses, and I can see the “display client” on my director 

computer. 

Solution: The client is not on the correct screen. The client must be on the screen that is your 

message center. To solve this, a few methods can be used: 

i. Right click on your desktop and select “Screen Resolution” or “Display Settings.” A dialog 

window will open; ensure that the “Multiple displays” drop down box is set to “Extend these 

displays.” The Windows + P shortcut can also be used to change this setting, select 

“Extend.” 

ii. Now if you still cannot see your content, you may have to try changing your main display 

(this can be found in the same dialog window mentioned above.) A restart of the computer 

may be needed to see the changes. Also, Windows + Arrow Key will move programs 

between displays. 

iii. Another fix that should be more permanent if the previous fixes are not working is to go to 

Tools > Edit Display Properties in Display Director, and in the dialog box, you will see the 

“Multiple Monitor Settings,” as seen in Figure 10-1. Select the Monitor that is not currently 

selected, ensure that the “Director and Client on same monitor” is not selected, and then 

save your changes. You will need to close and reopen Display Director and it should open 

as expected. 

Figure 10-1 
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10.1.2 Problem: An error message may pop up on opening, the client will not open, or the 

status light by the display preview will be red. 

Solution: It is possible that a setting was not set correctly upon installation. To edit these you will 

need to look at a few files. On your computer, navigate to C:\NEVCOFiles\Settings. Here you will 

see a files, DisplayInfo. Right click and select edit for this file. Find the line that says 

“<SignMode>X</SignMode>”. X will either be 0 or 1… for a single display setup, ensure that it is 0 

or change to 0 and save. Now reopen Display Director; it should be working. 

10.1.3 Problem: The live video input is not working. 

Solution: The live video may not be set up to work, or may be set up incorrectly. See the following: 

i. Check that the video format is set properly, see section 2.9 on setting up a your live stream 

ii. The video input is connected to the wrong port. This can be common with a composite 

single connected to the HD-SDI input on the DeckLink Studio 4k cards because they can 

both use coaxial BNC connectors. Figure 10-2 shows the proper place to connect a 

composite signal, from a TC-40 for example. Note that if you are using HDMI input, the 

bottom port is the input – in line with the SDI inputs on the main PCI card shown below.  

 

 
Figure 10-2 

 

 

Use this one for a 

composite signal 

Use this one for an HD-SDI signal 
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10.2 MULTIPLE DISPLAY SYSTEM  

A multiple display is one that runs on two or more computers, meaning that the controlling 

computer is the director, and the other computers (video boards) are running as clients. Following 

are common problems and solutions that occur within a multiple display system. If your answer is 

not below, please check the single display issues as some of them overlap. 

 

10.2.1 Problem: I cannot send files to my client. When attempting to send files, the progress 

window will show up but it will not show any progress. 

Solution: The computers have not been connected correctly. One of the following should be a 

solution to this problem:  

i. Follow the path: Control Panel > Network and Internet > Network and Sharing Center > 

Change advanced sharing settings > and ensure that “network discovery” and “file and 

printer sharing” are both turned ON and “password protected sharing” is turned OFF. 

ii. There are files that must be “shared” on your network. On each computer (director and 

client computers), navigate to the C:\ drive and locate the “NEVCOFiles” folder. Right click 

on this folder, and go to “Give access to” and select “Specific people…” Now, as seen in 

Figure 10-3, select “Everyone” in the drop down and click add, make sure the permission 

level is Read/Write, and click Share. Complete this process with the “C:\NEVCOLogs” 

folder as well. Make sure this is done on the director computer and all the client 

computers. You should now be able to send files to the client computer(s).  

 

 

 

Figure 10-3 



 

 

Display Director User Manual Display Director Version 3.5.2 46 

iii. A check to ensure you are connected properly is that after “sharing” the NEVCOFiles and 

NEVCOLogs folders, you should be able to access all of your computers from any of your 

computers. A good test for this is to go to your Windows “File Explorer” and type in 

“\\192.168.10.10” (or the IP address is of any computer other than the one you are using), 

and here you will see shared folders from this computer. If the NEVCOFiles and 

NEVCOLogs folders are there, you should be connected properly. Ensure this is true for 

all the computers in the system. If this is not the case, please review this whole solution.  

 

10.2.2 Problem: I see a Display Client on my Display Director machine. There should only be 

Display Director.  

Solution: A setting was not set up correctly. On the director computer, navigate to 

C:\NEVCOFiles\Settings and right click to select edit on the DisplayProps.xml file. We will be 

looking at the SignMode line, “<SignMode>X</SignMode>”. X can be 0 or 1. For a multiple 

display director, ensure that SignMode is set to 1 and if not, change it and save the file. Exit and 

reopen Display Director.  

10.2.3 Problem: I have a green light on my preview and I was able to send files… However, 

when clicking a button, it will not show up on my message center. 

Solution: A setting was mistakenly changed. Follow these steps: 

1. On the client computer, navigate to C:\NEVCOFiles\Settings and right click to select edit 

on the DisplayProps.xml file. We will be looking at the SignMode line, 

“<SignMode>X</SignMode>”. X can be 0 or 1. For a multiple display client, ensure that 

SignMode is set to 1 and if it not, change it and save the file. Exit and reopen the display 

client. This will have to be done for each client computer that is not operating.  

2. Make sure that the display name matches on both computers. In the DisplayInfo.xml 

(director computer) and the DisplayProps.xml (client computer) is where you will find the 

display name, “<Name>DisplayNameHere</Name>”. Change these lines in these files so 

that they match. Ensure to restart both programs and then to send files again.  

3. If the buttons are still not working or the SignMode settings were correct, proceed to 

problem 10.2.4. 

 

10.2.4 Problem: I did problem 10.2.3, but the buttons are still not working. 

Solution: If the buttons are still not working or the SignMode settings were correct, there may be a 

problem with the subnet masks of your computers. 

1. The broadcast address of the network must be 255. This is a hardcoded setting of Display 

Director and to get your system to operate correctly, you will need to change your network 

settings so that the broadcast address of your network is 255. This is standard, but it can 

sometimes be set otherwise.  

2. The subnet masks of each computer must match. To find the Subnet Mask of the 

computer, open the command prompt (can use search bar to open this in Windows). Type 

“ipconfig” and hit enter in the command prompt. Below the IPv4 address, there will be a 

Subnet Mask line. The subnet mask should look like 255.255.255.0. This must be checked 

for each computer. If it does not match (for example, it is 255.255.0.0), it will not work. The 

subnet mask must be changed.  
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3. Follow the path: Control Panel > Network and Internet > Network and Sharing Center. 

Now under “View your active networks” there will something like “Connections: Ethernet 

2.” Click on the “Ethernet,” this will bring up a dialog window. In this dialog window, click 

Properties. 

4. Now you will see a list; double click on “Internet Protocol Version 4 (TCP/IPv4).” This will 

bring up the dialog window seen in Figure 10-4 on the following page (may not look exactly 

like the figure, but it will be similar.) 

5. Now that this window is open, select “Use the following IP address:” and type in the IP 

address that is associated with the computer you are on. Set the subnet mask to match 

the other computers, as seen in Figure 10-4. After this, you can hit OK and exit out of the 

windows that were opened. Make sure to change all computers’ subnet masks to match 

each other. IP addresses should be kept the same as before and should NOT match 

across computers. 

 

 

 

 

Figure 10-4 
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10.3 VIRTUAL SCORING  

Virtual scoring is the ability to create a scoreboard on an LED display. This can be done on a 

single or a multiple display system. When setting up a VSB for a multiple system, the controller is 

connected to the client computer. Setting up the virtual scoreboard (or VSB) has a few points of 

failure. This section assumes that Display Director is working normally for all other aspects and 

features. Following are common problems and solutions for virtual scoring. 

 

10.3.1 Problem: My virtual scoreboard is not working. The screen is blank. 

Solution: There are many different reasons why this may be. Check all of the solutions in this list 

(in order): 

 

i. The VSB Decryptor should be set up. There will be an icon on your desktop that shows 

three colored spheres (blue, green, and orange). Click on this and now there will be an 

icon in your status bar (lower right corner) with the same image, see Figure 10-5. Double 

click the spheres shown in your status bar. This will pull up a window, seen in Figure 10-6; 

In this window, ensure that the Server Type, Input File Path (FinishLynx), MPC Model 

Code (MPC), and COM Port (MPC) are all correct and match your system setup. Now, the 

Decryptor Output File Path must be correct. This output file path should be in the 

NEVCOFiles\NEVCOVSB and then the corresponding data type. Click “Add Server,” and 

now the gears should be in your status bar, as seen in Figure 10-5. 

a. If the gears are in your status bar, take a look at them – if the symbol next to them 

flashes between a green “play” symbol and a red “record” symbol, the MPC is 

sending data and the Decryptor is receiving data. There may also be a blue 

“pause” symbol; this is okay as long as no data is changing at the moment. When 

data is changed, it should no longer show only the blue “pause” symbol, though. 

You may have to double check the Decryptor settings if this is not as described. 

Figure 10-5 

Figure 10-6 
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b. Another thing to look at is the actual output file. Go to C:\NEVCOFiles\NEVCOVSB 

(on the director computer if single mode and on the client computer if in multiple 

mode). Now choose the data being used for the VSB. There should be a Nevco 

MPC0.xml file. Take a look at the last date and time the file was modified (make 

sure you are in “details” view). If you are feeding it data, it should be the current 

date and time. 

c. If using a multiple display setup, the Output File Path in Decryptor must be pointing 

to the client computer. This is done by setting the file path to be something like 

“\\COMPUTER\NEVCOFiles\StatCrew\GAME.xml” and replacing COMPUTER to 

be the client’s computer name or IP address and replacing GAME to be the file 

name. For a MPC the path will look something like this: 

“\\COMPUTER\NEVCOFiles\NEVCOVSB\NevcoMPC\Nevco MPC0.xml” where 

the 0 changes based on how many output files are setup in Decryptor. 

ii. Ensure that the Data Reader Setup includes your data reader. See section 6 of this 

manual for more information on the Data Reader and setting it up. Make sure that the 

output file path for Decryptor is the input file that the data reader is setup to read.  

iii. It is possible that virtual scoreboards are disabled. To enable, open Display Director, go to 

the main menu and find “Tools,” from here select “Edit Display Properties.” Now the 

window in Figure 10-7 will open. In this window, there is a section labeled “Scoreboard 

Options,” Underneath, Enable Stats must be checked and Scoreboard Data Source must 

be set to Nevco MPC; other virtual scoring methods will still work. For a multiple system, 

this also should be checked and changed if incorrect on the client computer. To do this, go 

to the panel in the bottom left of the client computer and click “PROPERTIES”. This will 

pull up a dialog similar to Figure 10-7. Now, virtual scoring should be enabled. 

 

 

 

Figure 10-7 

Figure 10-8 
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iv. The CG Overlay should be checked that the correct values are being used. When adding 

a data item, there is an options window as seen in Figure 10-8. For StatCrew, ensure that 

the Data Source is StatCrew and that the rest of the fields are selected so that the data 

you are trying display is correct. Keep in mind that if the Data Reader is setup to read a 

file, that file needs to have the Data Field’s information, otherwise it will not show up. If 

using FinishLynx, HyTek, or Nevco’s MPC, the Data Source should be set to NEVCO. 

After this, the Type must be selected accordingly. The type “VSB” is for using a Nevco 

MPC. The last two fields are now what you are trying to display on the VSB. Keep in mind 

that if using the Data Field of PlayerH or PlayerV, the player number must be set in the 

lower left corner of the CG Overlay Creator user interface. 

v. Ensure that the program you are using to input the data (MPC, StatCrew, FinishLynx, 

HyTek, or Stalker Radar) is turned on and operational or that the file being edited is saved. 

If using the Nevco MPC, ensure that the correct sport model is selected on the MPC. 

vi. Make sure that the CG Overlay is applied to the button that you are using. 

 

10.3.2 Problem: On a multiple system setup, there is data displayed on the client, but it will 

not update unless the “send files” icon is used. 

Solution: The VSB Decryptor is not set up to output the file in the correct location. It is setup to 

output to the director computer and instead of the client computer. Review problem 10.3.1, sub-

bullet i.c. 

 

10.3.3 Problem: There is data on my VSB, but it is incorrect. 

Solution: First check that your problem does not fall under problem 10.3.1. If it does not, this 

means that there must be one setting somewhere that is not correct. The possible settings that 

you can check are: 

i. If using a MPC, check the sport model being used on the MPC and check the model code 

that is being used on the Decryptor software. Review problem 10.3.1, bullets i and v. 

ii. Make sure the CG Overlay has the correct information, and possibly player number. 

Review problem 10.3.1, bullet iv. 

iii. Double check that the correct CG Overlay was added (possibly opening CG Overlay 

Creator and verifying the data, not just the file name). Review problem 10.3.1, bullet vi. 
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iv.  

10.3.4 Question: How do I connect FinishLynx ResulTV to Display Director? 

Solution: ResulTV creates a full screen track scoreboard on a laptop and connects to Display 

Director’s live video input. To show the track scoreboard on the video display simply connect it to 

the live video input capture card and click the GO LIVE button. The following diagram illustrates 

the FinishLynx integration: 

 
 


